www.iFourWinns.com

Dedicated to Current and Future Owners
It is currently Fri Nov 27, 2020 9:28 am

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 1 post ] 
Author Message
PostPosted: Thu Jul 25, 2019 12:47 pm 
Offline
Minnow

Joined: Thu Jul 25, 2019 10:43 am
Posts: 10
Location: San Gabriel CA.
Hey everyone,

I purchased a 2000 four winns horizon 230LT with a 7.4gi Volvo Penta it has the dp-sm outdrive. So far it’s been great but ever since we got it on the water we have had a issue with the engine cutting off and returning to idle and a loud beeping noise when hitting a wave or when boat is rocking and in forward motion. The engine never turned off or back fired. I’m thinking maybe a oil pressure issue I’ve changed the oil and filed it with factory oil to factory setting and it seemed to do it a lot more when I over filled it by a quart/ quart and a half it did it less but still having the issue... has anyone else had this issue? Faulty oil pressure switch/ or sensor? Any help would be greatly appreciated or share your past experience and what you did to fix would be awesome :D

_________________
Can always be reached at nickguerrera33@gmail.com


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: Google [Bot] and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group